N@i.jp  昨日:7496
 今日:2437
 総計:00130342
keywords
管理者専用
  Post   Add link   Control Panel 






























新しいトピック
最新:03/08 20:16


新しいコメント
最新:06/04 19:41






管理人へMAIL

プライバシーポリシー

PHP5.6 が EOL(1)

参照:PHP本家


今年 1月10日にリリースされた PHP 5.6.40 が PHP 5系の最終リリースとなった


 PHP の 5.6.40 が今年の1月10にリリースされ、これが PHP 5系の最終ブランチとなった。PHP 5系は EOL(End Of Life)となり、以後サポートは行われなくなる。
 PHP 7.0 もサポートが終了しており、現在メンテナンスされているのは 7.1系(2019/12まで)、7.2系(2020/11まで)、7.3系(2021/12まで)となっている。PHP 5系を使用している Webサーバは PHP 7.1かそれ以上へ移行する必要がある。

 実はウチのBlogも PHP 5.6.40 だったりするのである。今後、否応なくPHP 7.1かそれ以降へ移行しなければならないわけだが・・・PHP部分は全部オープンソースで、現在はサポートされていないような代物なので、自力で何とかしなければならない。しかも、PHP 4時代のソースなので、PHP 7では削除されている関数、機能が使われている可能性が大だ(特にMySQL拡張モジュールの廃止により、MySQLi拡張モジュールに書き替える必要があるってのが大きい。とにかくmysql関数が大量に使用されているので、これを全部mysqli関数に書き換えるなんて気が遠くなる。まぁ、その前に PHP 7.1, 7.2, 7.3 のビルドが成功するのかも分からんが・・・)。
 PHP は勉強したこともないので、自力で何とかできるか正直全く自信がない。まぁいよいよダメだったら、このBlogも閉鎖ですかねぇ?


2019.1.27追記:
 少し試してみたが、MySQLiではDB接続がエラーになってしまうようだ。原因が良く分からんのだが、パスワードのフォーマットが古い16バイトハッシュ形式だとダメで、old_passwords=0 にしてとか何ちゃらかんちゃらで、ワタシにはハードル高そう・・・


< 過去の記事 [ 3月の 全てのカテゴリ リスト ] 新しい記事 >

2019 calendar
3月
12
3456789
10111213141516
17181920212223
24252627282930
31


掲示板
最新:08/15 17:19


GsBlog was developed by GUSTAV, Copyright(C) 2003, Web Application Factory All Rights Reserved.