絖綛 N@i.jp  昨日:00037480
 今日:00015476
 総計:00992267
keywords
管理者専用
  Post   Add link   Control Panel 































新しいトピック
最新:07/22 20:27


新しいコメント
最新:07/28 16:47






管理人へMAIL

プライバシーポリシー

PHP 8系に移行できるだろうか?(2)

ダメかもしれない・・・


 PHP 8.0系への移行を試みているのだけど、Apache module が PHP 8.0 のものになると異常終了するようになってしまった。エラーログの内容は以下のとおり。

[Thu Jan 19 14:13:26.995804 2023] [mpm_worker:notice] [pid 10351:tid 2684415368] AH00292: Apache/2.4.54 (Unix) PHP/8.0.27 OpenSSL/1.1.1s SVN/1.13.0 configured -- resuming normal operations
[Thu Jan 19 14:13:26.996346 2023] [core:notice] [pid 10351:tid 2684415368] AH00094: Command line: '/usr/local/apache2/bin/httpd'
[Thu Jan 19 14:13:37.892748 2023] [md:notice] [pid 10355:tid 25918976] AH10059: The Managed Domain y-naito.ddo.jp has been setup and changes will be activated on next (graceful) server restart.
[Thu Jan 19 14:13:56.011614 2023] [core:notice] [pid 10351:tid 2684415368] AH00052: child pid 10355 exit signal Bus error (10)

 どうやら Bus error(SIGBUS)が発生しているようだ。この現象は最初にビルドした PHP 8.0系の結構古いバージョンから発生していた。SIGBUSはメモリアライメントに違反したメモリアクセスによって発生する例外なので、PHPのバグである可能性がありそう。そう思って現時点の最新版である PHP 8.0.27 まで更新してみたが、一向に現象は変わらず。

 う〜ん、異常終了するとは思っていなかったなぁ。これ直せるかどうか・・・ワタシには無理かもなぁ。


■ このトピックへのコメント投稿フォーム ■
キャンセル
※ HTMLタグは使えません
* 名前
* MAIL
* URL
本文
PASS ※ 半角英数8文字まで
認証 ※ 九四零九八を半角数字で入力して下さい
  * 印の項目をcookieに保存する

2023 calendar
1月
1234567
891011121314
15161718192021
22232425262728
293031


掲示板
最新:08/15 17:19


GsBlog was developed by GUSTAV, Copyright(C) 2003, Web Application Factory All Rights Reserved.